Engraver Not working.

NEJE KZ usb laser engraver
Post Reply
Posts: 1
Joined: Sat Jul 17, 2021 2:45 pm

Engraver Not working.

Post by Sleepy0905 »

Well went to do a quick job and found that the machine no longer worked so after some carefull Circuit probing I found that the drivers for the stepper motors wasn't working so I ordered some new TC118S sop-8 chips, well they have arrived and some carefull hot air rework and all 4 of these chips have now been replaced and my engraver now works again.
tc118s.jpg (73.5 KiB) Viewed 2128 times
Site Admin
Posts: 153
Joined: Sat Nov 21, 2020 4:00 am

Re: Engraver Not working.

Post by dav »

User avatar
Posts: 6
Joined: Thu Aug 26, 2021 2:58 am


Post by RTrob »

Update: I just tried turning on the controller again and its been working fine for the last 20 minutes or so. Im still a little concerned since I have no idea what was wrong in the first place and I dont know if its completely fixed or not.
Posts: 37
Joined: Thu Jun 17, 2021 2:17 am

Re: Engraver Not working.

Post by JackWong »

The possible cause of your problem is that you have connected 12V power supply instead of 5V power supply to your device, which will damage the TC118 chip. If your device works normally, you have done a great job
Post Reply